Cisco 877, ADSL, PPPoE и «СЗТ»

Побаловался. Никакой особенной ценности в этом конфиге нет, он базовый и широко представлен в немного различающихся ароматах в интернете (здесь, здесь и далее по гуглу). Приделан еще DHCP-сервер, который выдает DNS-ы, полученные от провайдера.

Примечание: если вы будете копировать эту конфигурацию, обратите внимание, что здесь настроен логин с именем admin и паролем MyPaSsWoRd. Кроме того, возможно, вам потребуется что-то изменить в строке ppp pap sent-username szt password 0 szt — здесь имя и пароль от вашего провайдера. Наконец, pvc 8/35 — это ваши VPI/VCI, измените их, если нужно.

!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
dot11 syslog
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool HOME
   import all
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
!
!
!
multilink bundle-name authenticated
!
!
username admin privilege 15 secret 0 MyPaSsWoRd
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.1 point-to-point
 pvc 8/35
  encapsulation aal5snap
  pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
!
interface Dialer1
 ip address negotiated
 ip mtu 1400
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip route-cache flow
 dialer pool 1
 no cdp enable
 ppp authentication pap callin
 ppp pap sent-username szt password 0 szt
 ppp ipcp dns request
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer1 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
 no modem enable
line aux 0
line vty 0 4
 logging synchronous
 login
!
scheduler max-task-time 5000
end

  • Дмитрий

    Спасибо. Оная конфига работает :)

    И хоть оно есть там и там, практически без правок заработала именно эта.

    Правда ISP — Дальсвязь, но думаю это тот же флаг, ток в другой руке.

  • http://ogarkov.com/ Дмитрий Огарков

    Очень рад:) На здоровье.